I am talking about the website www.reddit.com

I have a reddit account that I created using Tails and have only ever accessed when using Tails. Yesterday I finally got around to downloading Tails version .10 but when I tried to log into Reddit this morning it didn't work. I can type my user name and password in, but when I click the "login" button the page just resets.

I remember reading a post mentioning this on reddit not long ago by a mac user. People told him to enable cookies:

http://www.reddit.com/r/onions/comments/n3izp/i_am_using_the_tor_bundle_and_i_cannot_log_into/

I have tried enabling cookies. I can log into other sights such as Gmail and they work fine. My operating system is Linux Mint. I don't know what else to do.

Thanks for any help.

I just registered an account, which worked. I also got automatically logged in to it. After logging out I had no problem logging back in, but I can confirm this bug when trying to log in after also restarting the browser.

It seems to be an issue with NoScript since the following workaround works: NoScript preferences -> "Advanced" tab -> "HTTPS" tab -> "Cookies" tab: uncheck "Automatic secure cookie management". Note that this settings will be reset on browser restart.

Comment by Tails Mon 16 Jan 2012 03:42:00 PM CET